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Figure 24: Edit Relationships Dialog Box
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Activity 2: Form Creation and Test Data Entry

Activity 2 requires you to design Customer, Item, and Enroliment forms, as well as use
the forms to enter test data. When designing these forms, you can use Figures 36, 39,
and 42 as references. Once the forms are created, you can use the forms to enter the
data shown in Figures 43 - 45.
Task 1: Create the Customer Form

To create the Customer form, you can:'

1. From the Forms group located on the Create tab, click the More Forms button.

2. From the drop-down menu, select the Form Wizard option. See Figure 25.

3. Click the drop-down arrow, and select tblCustomer. Add all the tbiCustomer fields
to the form. See Figure 26. Click the Next button.

4. Select the columnar layout. See Figure 27. Click the Next button.
5. Select the Access 2007 style. See Figure 28. Click the Next button.

6. Name the form “frmCustomer”. See Figure 29. Click the Finish button. The initial
Customer form is displayed. See Figure 30.

7. From the Views group, click the down arrow on the View button, and then select
Design view. Figure 31 shows the initial Customer form in Design view.

8. If the Field List box is open, click the Close button on the Field List box.
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_ Place the mouse pointer on top of the Detail Section Bar. When the mouse pointer

changes to a double-headed arrow _h with a thick line between the arrow heads,
drag downward until the header section is approximately one inch.

Resize the form's border width to approximately seven inches. See Figure 32.

In the Form Header section, select the control containing the text “frmCustomer”
and then position and resize the control as shown in Figure 32.

While the control is still selected, set the font size to 20; bold and center the text
“frmCustomer”. See Figure 32.

Click inside the frmCustomer control and change the text to read “Customer Form”.

From the Controls group located on the Design tab, select the Label button located
on the Toolbox toolbar. See Figure 33.

Place your mouse pointer in the Form Header section; then drag to size the control.
Use Figure 34 as a guide.

Type the words “Timeka's Tahning Salon” inside the control. Set the font size to 26;
set the font color to Access Theme 10. (Access Theme 10 is located in the Access
Theme Colors group, and is in Column 10, Row 2.)

Bold and center the text inside the control.

Position the control so that its contents will appear centered on the form.

Move to the Detail section. Select the controls, and then right-click.

From the Shortcut Menu, select Layout, and then select the Remove command.
Using Figure 34 as a guide, reposition the field controls and their labels.

Double click the CID label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, type “Customer Identification Number:”. See
Figure 35.

Close the Property Sheet window.

Bold and right justify the CID label.

Double click the LastName label. The Property Sheet window should appear. Click
the Format tab. In the Caption box, type “Last Name:". Close the Property Sheet

window.

Bold and right justify the LastName label.
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. Double click the FirstName label. The Property Sheet window should appear. Click
the Format tab. In the Caption box, type “First Name:”. Close the Property Sheet
window.

. Bold and right justify the FirstName label.

. Double click the PhoneNumber label. The Property Sheet window should appear.
Click the Format tab. In the Caption box, type “Phone Number:”. Close the
Property Sheet window.

. Bold and right justify the PhoneNumber label.

. Double click the SAddress label. The Property Sheet window should appear. Click
the Format tab. In the Caption box, type “Street Address:”. Close the Property
Sheet window.

. Bold and right justify the SAddress label.

. Double click the City label. The Property Sheet window should appear. Click the

Format tab. In the Caption box, insert a colon after “City”. Close the Property
Sheet window.

. Bold and right justify the City label.

. Double click the State label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, insert a colon after “State”. Close the Property
Sheet window.

. Bold and right justify the State label.

. Double click the ZipCode label. The F’ro’perty Shéet window should appear. Click
the Format tab. In the Caption box, type “Zip Code:”. Close the Property Sheet
window,

. Bold and right justify the ZipCode label.

. While holding down the Shift key, click each control in the Detail Section (CID,
LastName, FirstName, PhoneNumber, SAddress, City, State, and ZipCode).

. Click the down arrow beside the Font Color button. From the Access Theme colors
group, select Access Theme 9 (row 2, Column 9).

. Make any other adjustments that you feel are necessary to improve the Customer
form's appearance. See Figure 36.

. Save the form.
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Figure 25: Form Wizard Command
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Figure 27: Form Wizard Layout Dialog Box
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Figure 29: Form Wizard Name Dialog Box
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Figure 31: Initial Customer Form in Design View

# Form Header

: i LastMame

I} # Detail Firstiame
) E! PhonsMumber |
- | Shddress i

City

R State
= ZipCode

Show el tables

T T e

il # Form Foater -

Figure 32: Customer Form with Increased
Header Section and Border Width

i
]

o
it

[T € Fom tieader

CiD

iLastName

P

o B2

bl Tk e R

EimpCGdé

’

319




*——

5 mitle

#] Page Humbers |
(53 Date and Time

Database Tutorial

Figure 33: Controls Group
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Figure 34: Customer Form in Design View
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Figure 35: Property Sheet Window
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Task 2: Create the ltem Form
To create the ltem form, you can:
1. From the Forms group located on the Create tab, click the More Forms button.
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. From the drop-down menu, select the Form Wizard option.
. Click the drop-down arrow, and select tblltem.

. Add all the tblltem fields to the form. Click the Next button.

Select the Columnar layout. Click the Next button.

. Select the Access 2007 style. Click the Next button.
. Name the form “frmitem”. Click the Finish button. The initial ltem form is displayed.

. From the Views group, click the down arrow on the View button, and then select

Design view. See Figure 37.

. If necessary, click the Close button on the Field List box.

Place the mouse pointer on top of the Detail Section Bar. When the mouse pointer
L
s
changes to a double-headed arrow = with a thick line between the arrow heads,
drag downward until the header section is approximately one inch.

Resize the form's border width to approximately seven inches. See Figure 38.

In the Form Header section, select the control Containing' the text “frmltem” and then
position and resize the control as shown in Figure 38.

While the control is still selected, set the font size to 20: bold and center the text
“frmltem”.

Click inside the frmltem control and change the text to read “ltem Form”.

From the Controls group located on the Design tab, select the Label button located
on the Toolbox toolbar. Refer back to Figure 33.

Place your mouse pointer in the Form Header section; then drag to size the control.
Use Figure 38 as a guide.

Type the words “Timeka's Tanning Salon” inside the control. Set the font size to 26;
set the font color to Access Theme 10. (Access Theme 10 is located in the Access
Theme Colors group, and is in Column 10, Row 2.)

Bold and center the text inside the control.

Position the control so that its contents will appear centered on the form.

Move to the Detail section. Select the controls, and then right-click.

From the Shortcut Menu, select Layout, and then select the Remove command.
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Using Figure 38 as a guide, reposition the field controls and their labels.

Double click the IType label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, type “Item Type:”. Close the Property Sheet
window.

Bold and right justify the IType label.

Double click the Description label. The Property Sheet wiﬁdow should appear.
Click the Format tab. In the Caption box, type a colon after Description. Close the
Property Sheet window.

Bold and right justify the Description label.

Double click the Price label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, type a colon after Price. Close the Property Sheet
window.

Bold and right justify the Price label.

While holding down the Shift key, click each control in the Detail section (IType,
Description, and Price).

Click the down arrow beside the Font Color button. From the Access Theme colors
group, select the Access Theme 9 (row 2, Column 9).

31. Make any other adjustments that you feel are necessary to improve the ltem form’s
appearance. See Figure 39.
32. Save the form.
Figure 37: Initial ltem Form
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Figure 38: Final Item Form in Design View
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Task 3: Create the Enrollment Form

To

.

2,

create the Enroliment form, you can:

From the Forms group located on the Create tab, click the More Forms button.
From the drop-down menu, select the Form Wizard option.

. Click the drop-down arrow, and select tbIEnroliment.

. Add all the tblEnrollment fields to the form. Click the Next button.

. Select the Columnér layout. Click the Next button.

. Select the Access 2007 style. Click the Next button.

. Name the form “frmEnrollment”. Click the Finish button. The initial Enrollment form
is displayed. See Figure 40.

324




10.

11.

12.

13.

14.

15.

16.

17.

18.

19,

20.

21

22.

23.

24.

25.

26.

Database Tutorial

. From the Views group, click the down arrow on the View button, and then select

Design view.

. If necessary, click the Close button on the Field List box.

Place the mouse pointer on top of the Detail Section Bar. When the mouse pointer
i it -

changes to a double-headed arrow = with a thick line between the arrow heads,

drag downward until the header section is approximately one inch.

Resize the form's border width to approximately seven inches.

In the Form Header section, select the control containing the text “frmEnroliment”
and then position and resize the control as shown in Figure 41.

While the control is still selected, set the font size to 20; bold and center the text
“frmEnrollment”. See Figure 41.

Click inside the frmEnroliment control and change the text to read “Enroliment
Form”.

From the Controls group located on the Design tab, select the Label button located
on the Toolbox toolbar. Refer back to Figure 33.

Place your mouse pointer in the Form Header section; then drag to size the control.
Use Figure 41 as a guide.

Type the words “Timeka's Tanning Salon” inside the control. Set the font size to 26;
set the font color to Access Theme 10. (Access Theme 10 is located in the Access
Theme Colors group, and is in Column 10, Row 2.)

Bold and center the text inside the control.

Position the control so that its contents will appear centered on the form.

Move to the Detail section. Select the controls, and then right-click.

From the Shortcut Menu, select Layout, and then select the Remove command.
Using Figure 41 as a guide, reposition the field controls and their labels.

Double click the ENID label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, type “Enroliment Identification Number:”. Close the
Property Sheet window.

Bold and right justify the ENID label.

Double click the CID label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, type “Customer Identification Number:”. Close the

Property Sheet window.

Bold and right justify the CID label.
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Double click the IType label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, type “Item Type:”. Close the Property Sheet
window.

Bold and right justify the IType label.

Double click the EDate label. The Property Sheet window should appear. Click the
Format tab. In the Caption box, type “Enroliment Date:”. Close the Property Sheet
window.

Bold and right justify the EDate label.

While holding down the Shift key, click each control in the Detail section (ENID,
CID, IType, and EDate).

Click the down arrow beside the Font Color button. From the Access Theme colors
group, select Access Theme 9 (row 2, Column 9).

While the controls are still selected, click the Property Sheets button located in the
Tools group. "

In the Border Width box, click the drop down arrow and select 1pt.

Make any other adjustments that you feel are necessary to improve the tem form's
appearance. Figure 42 shows the final Enrollment form.

Save the form.

Figure 40: Initial Enrollment Form in Design View
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Figure 41: Enrollment Form in Design View After Changes
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Figure 42: Enrollment Form in Form View
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Task 4: Enter the Customer, ltem, and Enrollment Data

1. Use your newly created Customer form to enter the customer data shown in Figure
43.

2. Use your newly created ltem form to enter the item data shown in Figure 44.

3. Use your newly created Enroliment form to enter the enrollment data shown in
Figure 45.
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Figure 43: Customer Data

Customer
Identification
Number Last Name First Name | Phone Number Street Address City State Zip Code
1|Grant Mitchell (999)555-1255 |1010 Boulevard Rd. San Francisco CA S4111
2|Sasser Lexina (999)555-6456 {210 Rushing Meadows San Francisco CA 94112
3|Rother Eiwood (999)555-6577 3001 Ripple Cresk San Francisco CA 94113
4|Chen Shibo (9989)555-4789 15712 Tanglewood Road San Francisco CA 94113
5|Elotmani Damir (899)555-3812 12121 Hyde Parke San Francisco CA 84115
B|Schoenhals Eliah (999)555-6058 |1920 Pine Drive San Francisco CA 94111
7|Erbst Troy (999)555-1300 {1780 Glacier Drive San Francisco CA 94112
8| Ottinger Clarissa (999)555-9351 | 11908 Coltrane San Francisco CA 94112
9|Blochowiak Edith (999)555-0202 |1223 Ridgewood San Francisco CA 94115
10|Harley Sasha (999)555-5931 |10625 Brighton San Francisco CA 94115

Figure 44: Item Data

item Type Description Item Price
SE001 5 One Session $5.00
SE002 5 Sessions $25.00
SEO003 10 Sessions $50.00
SE0Q4 15 Sessions $75.00
SE005 20 Sessions $100.00
SP001 One Month Unlimited $35.00
SP002 Monthly Special $30.00
SP003 Loyal Customer $29.99
SP004 Referral $29.99
SP005 Yearly Enroliment $350.00
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Figure 45: Enrollment Data

Customer Last Name Description Enrollment Date
Sasser _ 5 Sessions 1/17/2007
Rother One Moanth Unlimited 1/18/2007
Chen 10 Sessions 1/15/2007
Elotmani One Session -1/18/2007
Schoenhals Loyal Customer 1/18/2007 |
Erbst 15 Sessions 1/18/2007
Ottinger One Month Unlimited 8/15/2007
Blochowiak 10 Sessions 8/15/2007
Harey 5 Sessions 8/20/2007

Activity 3: Query Creation

Activity 3 creates three queries. The first query, qrySingleSession, identifies how many
customers have purchased a single tanning session. The second query, gryinactive,
identifies the salon's customers who are not currently enrolled. The third query,
gryNewEnrollment, identifies the customers that enrolled after August 1, 2007.

Task 1: Create the qrySingleSession Query

1. From the Other group located on the Create tab, click the Query Design button.
See Figure 46. it %

2. The Query Design view and the Show Table dialog box open. (If the Show Table
dialog box is not open, click the Show Table button located in the Query Setup
group.)

3. In the Show Table dialog box, double click tblEnrollment and tblltem. The field lists
for both tables should now be added to the top pane of the Query Design window.
Click the Close button.

4. Add the Description field from the tblitem table and the ltype field from the
tblEnroliment table to the query design grid. (You can add a field by double clicking
its name.)

5. From the Show/Hide group, click the Totals button. See Figure 47.

6. In the Total row for the IType field, click the drop-down arrow and select Count from

the drop-down list. (If the drop-down arrow is not showing, just click by the word
“By”. The drop-down arrow should now appear.)

329




